Learn HTML by Building a Cat Photo App - Step 15

Tell us what’s happening:
Describe your issue in detail here.
I have been working on this step of the cat webpage for a little while now and I just can’t seem to figure out where I am going wrong.
Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>

<!-- User Editable Region -->

     <a href="https://freecatphotoapp.com"
     <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg"</a>

<!-- User Editable Region -->

    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/111.0.0.0 Safari/537.36

Challenge: {{challengeTitle}} Learn HTML by Building a Cat Photo App - Step 15

Link to the challenge:

Hi there, you just need to make sure your elements are properly closed. You don’t have the a element closed nor the img element. You need a > around the a element like so:

<a href="https://freecatphotoapp.com">

And a > to close off the img element as well:

<img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg"></a>

Putting it all together (with some more spacing so you can see it more clearly):

<a href="https://freecatphotoapp.com">
    <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg">
</a>
1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.