Learn HTML by Building a Cat Photo App - Step 15

Tell us what’s happening:
Describe your issue in detail here.
It’s saying “You should only add one opening anchor (a ) tag.”. I only have used one <a though. I’ve been stuck on this bit for a while now.
Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>

<!-- User Editable Region -->

<a href=https://freecatphotoapp.com> <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">

<!-- User Editable Region -->

    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/113.0.0.0 Safari/537.36 OPR/99.0.0.0

Challenge: Learn HTML by Building a Cat Photo App - Step 15

Link to the challenge:

Hi there and welcome to our community!

The error message is a little misleading. The issue with your code is that you are missing the closing anchor tag, after the img element.
Also, your href attribute doesn’t have the correct syntax, as the value should be enclosed in double quotes.

2 Likes

Awesome. Thank You. Worked Perfect Now.

1 Like

Technically, the test is correct.

The code does create an extra a element. Well, the runtime/browser creates it. It closes the first a element automatically and then it creates an empty element after the main element.

extra-element

It is just one of those weird things that happen when you do not close elements properly.

Anyway, good job fixing it.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.