Learn HTML by Building a Cat Photo App - Step 15

I’m having problems adding attribute tags to the img link

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>
     <a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg." alt="A cute orange cat lying on its back."><a/>
    </main>
  </body>
</html>

Your mobile information:

Redmi 7 - Android 10 - Android SDK 29

Challenge: Learn HTML by Building a Cat Photo App - Step 15

Link to the challenge:

This doesn’t look right. Compare it to the closing a tag on the “cat photos” link you created earlier.

I don’t understand what you mean but I’ll check and compare them

In addition to the closing a tag I also just noticed that you added a dot to the end of the image URL which wasn’t there in the starter HTML. Be sure not to make any extra changes you weren’t asked to make in the instructions. Even the smallest unexpected change can cause the tests to fail. And in this case, adding a dot at the end of the URL changes the URL completely and thus the image won’t show any more.

2 Likes

Hello!

Just a small typo that we all have committed. The / should not be behind at the end of the closing tag. But, I am sure it was just a typo that we all encounter and never see until we get another set of eyes on it.

As I said, we all have done it and will do it again.

Keep up your good progress!

1 Like

hey!
I’m just seeing the typo now. turns out that’s where the problem is. thank you!

1 Like

alright. thank you so much.

1 Like