Learn HTML by Building a Cat Photo App - Step 15

Tell us what’s happening:
Describe your issue in detail here.
it says my opening tag is wrong while i am sure it is orrect
Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>

<!-- User Editable Region -->

      <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back." <a href='https://freecodecamp.org'></a></p>

<!-- User Editable Region -->

    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/118.0.0.0 Safari/537.36

Challenge: Learn HTML by Building a Cat Photo App - Step 15

Link to the challenge:

Your opening a tag is correct but it is in the wrong spot. When you want to turn something into a link you need to surround it with an anchor element. This means putting an opening a tag before it and a closing a tag after it. Just like you did to the words “cat photos” in the previous steps.

Actually, I take back part of what I said above. The formatting of your opening a tag is correct but you are using the wrong URL for the href attribute. Be sure you are using the URL specified in the instructions.

Also, be sure not to make any unnecessary changes, like removing the closing > on the img tag. Remember, a tag always starts with < and ends with >.

your img is not closed , (a) href is not correctly linked,and you have a closing p that you dont need,

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.