Learn HTML by Building a Cat Photo App - Step 15

Tell us what’s happening: Hello, Ive been stuck on this step for a day now. im getting the message “You are missing a closing (a ) tag after the image.” When I put a closing tag after image the message says " You should only add one closing anchor (a ) tag. Please remove any extras. im confused

Describe your issue in detail here.

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>

<!-- User Editable Region -->

  <a href="https//freecatphotoapp.com"/a> <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg"</a> alt="A cute orange cat lying on its back."

<!-- User Editable Region -->

    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.3 Safari/605.1.15

Challenge Information:

Learn HTML by Building a Cat Photo App - Step 15

1 Like

You appear to have created this post without editing the template. Please edit your post to Tell us what’s happening in your own words.
Learning to describe problems is hard, but it is an important part of learning how to code.
Also, the more you say, the more we can help!

1 Like

Welcome to the community.

Here are a couple of problems with the code.

  1. The img element is missing the closing angle bracket > just before the closing anchor tag.

2: The link is missing the colon after https before the //:

  1. Remove the space between the opening anchor and the opening img brackets.

I hope this helps you.

Wishing good progress!

2 Likes

Was this able to help you move on to the next step?

1 Like

Ive put the closing Angle bracket before the closing anchor tag and still getting the missing (a) tag after the image

1 Like

Could we please see your updated code?

Did you add the : after the https in the anchor?

And, remove the space between the anchor and the img?

I apologize. The closing anchor should be after the closing of the img.
This should be at the very end after the alt value.

Example:
<a href="some url"><img and all included code></a>
2 Likes

thanks for the help, that example help me get it to work.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.