Learn HTML by Building a Cat Photo App - Step 15

Tell us what’s happening:

Describe your issue in detail here.
I keep getting an incorrect code message and it won’t let me move on when it is literally exactly how its supposed to look, or am I totally wrong. I’m getting very downtrodden and thinking this might not be for me if I’m struggling so early on. This is extremely frustrating!!!

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>

<!-- User Editable Region -->

      <a href="freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>

<!-- User Editable Region -->

    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36

Challenge Information:

Learn HTML by Building a Cat Photo App - Step 15

You appear to have created this post without editing the template. Please edit your post to Tell us what’s happening in your own words.
Learning to describe problems is hard, but it is an important part of learning how to code.
Also, the more you say, the more we can help!

The code I have so far is the exact code its supposed to be when I jump forward to step 16, it looks exactly the same, but yet, its telling me the code is incorrect because it doesn’t have a closing tag? The closing tag is where its supposed to be.

Welcome to the FFC forum.
Your link is missing something check it carefully in the instructions.
@DDay9