Learn HTML by Building a Cat Photo App - Step 15

Tell us what’s happening:

I feel so stuck I don’t know what I’m doing wrong here. I’m not passing this.

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>

<!-- User Editable Region -->

      <a href="http://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>

<!-- User Editable Region -->

    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/123.0.0.0 Safari/537.36

Challenge Information:

Learn HTML by Building a Cat Photo App - Step 15

this is incorrect

re read the directions more carefully for the correct value to pass the tests

I dont understand whats wrong with it ive been trying to figure this out since yesterday and i don’t know where to put the anchor. I feel like its probably obvious but i don’t know.

Your code is 99% correct

You did the anchor element correct here

your issue is that you incorrectly copied the href value here

you wrote http

but that part is incorrect

here are the directions again for the correct value

Use https://freecatphotoapp.com as the anchor’s href attribute value.

once you fix that, then it will pass

hope that helps

I figured it out, thanks!

2 Likes