Learn HTML by Building a Cat Photo App - Step 29

Tell us what’s happening:
Describe your issue in detail here. Can’t figure error even though I did according to given instructions, and there was no instruction for adding alt

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <section>
        <h2>Cat Photos</h2>
        <!-- TODO: Add link to cat photos -->
        <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>
        <a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>
      </section>
      <section>
        <h2>Cat Lists</h2>
        <h3>Things cats love:</h3>
        <ul>
          <li>cat nip</li>
          <li>laser pointers</li>
          <li>lasagna</li>
        </ul>
        <figure>
          <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/lasagna.jpg" alt="A slice of lasagna on a plate.">
          <figcaption>Cats <em>love</em> lasagna.</figcaption>  
        </figure>
        <h3>Top 3 things cats hate:</h3>
        <ol>
          <li>flea treatment</li>
          <li>thunder</li>
          <li>other cats</li>
        </ol>
        <figure>
          <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/cats.jpg.">
        </figure>
      </section>
    </main>
  </body>
</html>

Your mobile information:

vivo 1811 - Android 8.1.0 - Android SDK 27

Challenge: Learn HTML by Building a Cat Photo App - Step 29

Link to the challenge:

1 Like

You appear to have created this post without editing the template. Please edit your post to Tell us what’s happening in your own words.
Learning to describe problems is hard, but it is an important part of learning how to code.
Also, the more you say, the more we can help!

Remove the last dot as no valid URL ever ends with a dot

3 Likes

It look good! I wonder if you need to add an “alt=” in the last ‘img’ tag as well. Happy coding!

The instructions do not ask for an alt attribute.

1 Like

This works!!! Great for this help. While trying to write this comment i get a error saying"Post must be at least 20 characters" why is that happening?

2 Likes

I guess because the minimum character requirement keeps the forum from being a place were people make pithy comments (you can use the like or thumbs up for example instead of saying ‘thanks’ or ‘okay’)

2 Likes

I did, actually I typed the whole URL instead of copy paste but still it’s showing same error instructions

You may have another error then. Please copy the code in your response so we can take another look.
Make sure the code has a line that has three backticks above it and below it so it is formatted properly on the forum like this:
```
Code here
```