Learn HTML by Building a Cat Photo App - Step 37

Tell us what’s happening:
Describe your issue in detail here.
I’m stuck on step 37
got the hint “Your input element should have a type attribute with the value text. You have either omitted the value or have a typo.”

However I couldn’t find the typo or figure out my mistake after googling it

  **Your code so far**
<html>
<body>
  <h1>CatPhotoApp</h1>
  <main>
    <section>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>Click here to view more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a>.</p>
      <a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>
    </section>
    <section>
      <h2>Cat Lists</h2>
      <h3>Things cats love:</h3>
      <ul>
        <li>cat nip</li>
        <li>laser pointers</li>
        <li>lasagna</li>
      </ul>
      <figure>
        <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/lasagna.jpg" alt="A slice of lasagna on a plate.">
        <figcaption>Cats <em>love</em> lasagna.</figcaption>  
      </figure>
      <h3>Top 3 things cats hate:</h3>
      <ol>
        <li>flea treatment</li>
        <li>thunder</li>
        <li>other cats</li>
      </ol>
      <figure>
        <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/cats.jpg" alt="Five cats looking around a field.">
        <figcaption>Cats <strong>hate</strong> other cats.</figcaption>  
      </figure>
    </section>
    <section>
      <h2>Cat Form</h2>
      <form action="https://freecatphotoapp.com/submit-cat-photo">
        <input type="text">
      </form>
    </section>
  </main>
</body>
</html>
  **Your browser information:**

User Agent is: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:99.0) Gecko/20100101 Firefox/99.0

Challenge: Learn HTML by Building a Cat Photo App - Step 37

Link to the challenge:

I’ve just passed the tests with this line of yours.

Try to reset the step and complete the task.

Let me know please how it goes.

Screenshot from 2022-07-16 13-02-01
Didn’t work

Well, that’s strange. Just double-checked. For me its working.
I can’t help you if its technical issue, but I think somebody will give you appropriate advice about this.

Your code for this, however, is OK, that’s for sure.
Consider to move to the next step, you can always go back to this later.

Thank you for your help. I tried moving on to step 38 but I think I may be having the same problem again.
Screenshot from 2022-07-16 13-37-08

1 Like

Well, that’s unfortunate, some technical problems here. Sorry, I am not experienced enough to deal with this kind of issues.

All good I really appreciate the help as I was getting quite confused trying to figure out what I was doing wrong .

mod edit: solution image removed

1 Like

This happened to me a lot, I would consider copying the code from the next step and seeing if it changes. If not just run the test again.

Edit: Only do this if you think for sure that you ar right

for the record, the exercise is asking for an input element without adding any attributes to it. (this was the cause of the failure)

1 Like