Learn HTML by Building a Cat Photo App - Step 37

Tell us what’s happening:

I’ve completed the challenge by following the instructions and yet the website says that my code is incorrect.

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <section>
        <h2>Cat Photos</h2>
        <!-- TODO: Add link to cat photos -->
        <p>See more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a> in our gallery.</p>
        <a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>
      </section>
      <section>
        <h2>Cat Lists</h2>
        <h3>Things cats love:</h3>
        <ul>
          <li>cat nip</li>
          <li>laser pointers</li>
          <li>lasagna</li>
        </ul>
        <figure>
          <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/lasagna.jpg" alt="A slice of lasagna on a plate.">
          <figcaption>Cats <em>love</em> lasagna.</figcaption>  
        </figure>
        <h3>Top 3 things cats hate:</h3>
        <ol>
          <li>flea treatment</li>
          <li>thunder</li>
          <li>other cats</li>
        </ol>
        <figure>
          <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/cats.jpg" alt="Five cats looking around a field.">
          <figcaption>Cats <strong>hate</strong> other cats.</figcaption>  
        </figure>
      </section>
      <section>
        <h2>Cat Form</h2>

<!-- User Editable Region -->

        <form action="https://freecatphotoapp.com/submit-cat-photo">
            <input type="text">
        </form>

<!-- User Editable Region -->

      </section>
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.0.0 Safari/537.36 Edg/119.0.0.0

Challenge Information:

Learn HTML by Building a Cat Photo App - Step 37

2 Likes

Hey. Welcome to our forum.
Your code is correct, it passed all tests.
Try resetting the lesson and run the same code.

Welcome to the community @LongClaw07 !

If the great guidance of @stephenmutheu does not work, please try the following ?

  • Refresh page (F5)
  • Some browser extensions, such as ad-blockers and dark mode extensions can interfere with the tests.
  • If you are having problems, recommendation is to disable extensions that modify the content or layout of pages, while taking the course.
    • Try a different browser.

I hope his guidance works, as it is the first step suggested. Not gets lost with resetting steps or changing browsers, it only affects the step you are trying to submit. So, no worries about your completed steps, or progress.

Happy coding!

1 Like

I have tried resetting the lesson. It still doesn’t work.

1 Like

I tried all of those. Still nothing. I just finished the exercise on my phone XD

2 Likes

Good for you!

So that would be using a different browser, or change extensions, and filters, correct?

I am happy for you finding the issue and moving on.

The above suggestions are usually made to help people when the code is good, but they are having difficulty with it not submitting.

Keep up the good progress, and happy coding!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.