Learn HTML by Building a Cat Photo App - Step 40

this looks wrong…

Please reset the step.
(click the reset button to change all of this back to what it was)

after this you will be presented with one line of code in the editor:
<input type="text" name="catphotourl">

You are to add a placeholder attribute to that one line of code.

Remember, an html attribute is just a key=“value” pair (just like type is an attribute with value of “text” for eg)

So add placeholder the same way you would add the type attribute

I don’t understand
I’ve try to replace the value of this but the refuse

which part did you not understand?

I hope you are able to click on the Reset button at least?

I did and I did as you said but the code still don’t work

okay, please post your new code here?

<input placeholder="https://freecatphotoapp.com" type="text" name="catphotourl" >

that’s my code

I’ve edited your code for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (').

okay, you have a placeholder attribute now, that is a good step forward.
But you don’t have the proper value for it.
The exercise says:

Add the placeholder text cat photo URL to your input element.

So you should use the text they gave instead

I just try but it still no working

pls share new code pls

it’s still not working

I can’t test your code as you have posted an image.
Please post your actual code.

I can’t see it because you have not enclosed it in a code block.
Please take a look at the instructions I posted earlier

 <input placeholder="cat photo URL" type="text" name="catphotourl">

I’ve try as you said but is not working

I have good news and bad news for you. The good news is that your solution works from my end. The bad news is that you have to try the methods below until one works for you. (Let me know if you need any clarification on these steps)

Click on the “Restart Step” button and force a refresh of your page with CTRL-F5 then try to paste the code in again.

or - Try the step in incognito or private mode.

or - Disable any/all extensions that interface with the freeCodeCamp website (such as Dark Mode, Ad Blockers, or Spellcheckers), and set your browser zoom level to 100%. Both of these factors can cause tests to fail erroneously.

or - Ensure your browser is up-to-date or try a different browser.

I hope one of these will work for you.

okay, please post your new code here?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.