Learn HTML by Building a Cat Photo App - Step 43

Tell us what’s happening:
Describe your issue in detail here.
Hi - I apologize if this has been asked before, I have looked everywhere.

I have looked at alot of different posts and none seem to be having my exact issue.

in most cases, they have not added type to the actual beginning button element, if you look, I believe I have done this by typing <{button type=‘submit’}>. Please ignore the {}, it’s so it would load. I’m not sure what I am doing wrong now, when I check the code it tells me I have not added a type attribute, but I do see I’ve entered type=‘submit’ here.

Thanks in advance!

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <section>
        <h2>Cat Photos</h2>
        <!-- TODO: Add link to cat photos -->
        <p>Click here to view more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a>.</p>
        <a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>
      </section>
      <section>
        <h2>Cat Lists</h2>
        <h3>Things cats love:</h3>
        <ul>
          <li>cat nip</li>
          <li>laser pointers</li>
          <li>lasagna</li>
        </ul>
        <figure>
          <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/lasagna.jpg" alt="A slice of lasagna on a plate.">
          <figcaption>Cats <em>love</em> lasagna.</figcaption>  
        </figure>
        <h3>Top 3 things cats hate:</h3>
        <ol>
          <li>flea treatment</li>
          <li>thunder</li>
          <li>other cats</li>
        </ol>
        <figure>
          <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/cats.jpg" alt="Five cats looking around a field.">
          <figcaption>Cats <strong>hate</strong> other cats.</figcaption>  
        </figure>
      </section>
      <section>
        <h2>Cat Form</h2>
        <form action="https://freecatphotoapp.com/submit-cat-photo">
          <input type="text" name="catphotourl" placeholder="cat photo URL" required>
          <button>   </button>
        <button type='submit'>submit</button>
        </form>
      </section>
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Safari/537.36

Challenge: Learn HTML by Building a Cat Photo App - Step 43

Link to the challenge:

I see two buttons here

2 Likes

Try swapping the single quotations (') for doubles ("). You seem to have doubles everywhere else.

<button type='submit'>submit</button>
<button type="submit">submit</button>

And as @JeremyLT said, you have two buttons.

1 Like

OH my lord! thank you! I’d been wracking my brain trying all different ways!

SMH!

Thanks again! and Thanks @teiResa

2 Likes