Learn HTML by Building a Cat Photo App - Step 47

Tell us what’s happening:
Describe your issue in detail here
This is my code for step 47 and it isn’t working, can someone tell me my mistake
Your code so far

<html>
  <body>
    <h1>CatPhotoApp</h1>
    <main>
      <section>
        <h2>Cat Photos</h2>
        <!-- TODO: Add link to cat photos -->
        <p>Click here to view more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a>.</p>
        <a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>
      </section>
      <section>
        <h2>Cat Lists</h2>
        <h3>Things cats love:</h3>
        <ul>
          <li>cat nip</li>
          <li>laser pointers</li>
          <li>lasagna</li>
        </ul>
        <figure>
          <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/lasagna.jpg" alt="A slice of lasagna on a plate.">
          <figcaption>Cats <em>love</em> lasagna.</figcaption>  
        </figure>
        <h3>Top 3 things cats hate:</h3>
        <ol>
          <li>flea treatment</li>
          <li>thunder</li>
          <li>other cats</li>
        </ol>
        <figure>
          <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/cats.jpg" alt="Five cats looking around a field.">
          <figcaption>Cats <strong>hate</strong> other cats.</figcaption>  
        </figure>
      </section>
      <section>
        <h2>Cat Form</h2>
        <form action="https://freecatphotoapp.com/submit-cat-photo">
          <label><input id="indoor" type="radio"> Indoor</label>
         <label><input id="outdoor" type="radio"> Outdoor</label>
          <input type="text" name="catphotourl" placeholder="cat photo URL" required>
          <button type="submit">Submit</button>
        </form>
      </section>
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36

Challenge: Learn HTML by Building a Cat Photo App - Step 47

Link to the challenge:

Do you get an error message? What does it say? What have you tried to fix it?

Looking at the code, the issue is not immediately obvious, so I need more information.

Your solution works for me. Please try one of the following steps to move forward.

  • Click on the “Restart Step” button and force a refresh of your page with CTRL-F5 then try to paste the code in again.

  • or - Try the step in incognito or private mode

  • or - Try a different browser or disable browser extensions that may interfere with the test.

We hope one of these will work for you.

I knew my code was right but why is it not working , i can literally see it on the preview page . i tried what you told me to do but to no avail. I’m just going to move on to the next lesson. Thanks fr your help

Careful, your browser will try to repair bad code in order to make it work, so you cannot always know that your code is ‘right’ because it ‘looks right’.

sometimes browser extensions interfere (like dark mode or others).
If you are able to try on a different browser or disable the extension perhaps that would make it work but if you move on, that is also okay…

I don’t have any extensions on but I’m thinking that if I finish the remaining 68 lessons and go back to that one it will stop glitching
Thanks again you’re the best

Something about your browser is glitching. You could try an alternative browser.