Learn HTML by Building a Cat Photo App - Step 55

Tell us what’s happening:
It will not pass my input, is something incorrect? I’ve already looked up multiple prior posts with resolved status yet it will pass me for some reason.

Is there something im missing?

Step 55

There’s another way to associate an input element’s text with the element itself. You can nest the text within a label element and add a for attribute with the same value as the input element’s id attribute.

Associate the text Loving with the checkbox by only nesting the text Loving in a label element and place it to the right side of the checkbox input element.
__

Your code so far

<input id='loving' type='checkbox'>
<label for='loving'>Loving</label>   

__

Challenge: Learn HTML by Building a Cat Photo App - Step 55
Link to the challenge:

The <label> element has to be on the same line of code as the <input> element and there has to be a space between the end of the input element and the beginning of the label element.

Still doesn’t pass me sadly :cry:

I recreated your code exactly and it worked for me. You couldve’ve messed up code somewhere else inside of your index.html file and because of that it isn’t letting you continue.

Is this input and label element inline with the <legend> element and inside of the <fieldset> element?

I accidently deleted all my prior code this step, so that could be a possibility. I tried to redo the steps to regain the prior code but to no avail.

You shouldn’t have to redo all the steps to regain code you accidentally deleted. If you open a new tab with the step you’re stuck on, you will have all the code that is confirmed working already in there for you.

@Oldii apparently there is a limit to how many times I can reply in a day since I just joined today. Here is what I would’ve replied to you with:

Weird :thinking:

You could always just CTRL + A, CTRL + C and then CTRL + V all the working code from step 54 into step 55.

1 Like

On step 54 I have all the prior work I did, I can do that challenge and when I arrive at 55 everything’s still gone. Any clue on how to fix?

Just tried that, doesn’t work either. Thanks for the help though, it is appreciated.

**nevermind that, it worked! Thanks