Learn String Manipulation by Building a Cipher - Step 91

Tell us what’s happening:

I am having trouble getting \n to work in my code.

I have tried using it at the beginning and inside of the print call.

(Outside the print call)

Ex: \n print(f’Encrypted text: {text}')

(Inside the print call)

EX: print(\n f’Encrypted text: {text}')

I have also tried it without the space between \n and f

Your code so far

text = 'mrttaqrhknsw ih puggrur'
custom_key = 'python'

def vigenere(message, key, direction=1):
    key_index = 0
    alphabet = 'abcdefghijklmnopqrstuvwxyz'
    final_message = ''

    for char in message.lower():

        # Append any non-letter character to the message
        if not char.isalpha():
            final_message += char
        else:        
            # Find the right key character to encode/decode
            key_char = key[key_index % len(key)]
            key_index += 1

            # Define the offset and the encrypted/decrypted letter
            offset = alphabet.index(key_char)
            index = alphabet.find(char)
            new_index = (index + offset*direction) % len(alphabet)
            final_message += alphabet[new_index]
    
    return final_message

def encrypt(message, key):
    return vigenere(message, key)
    
def decrypt(message, key):
    return vigenere(message, key, -1)

# User Editable Region

\n print(f'Encrypted text: {text}')
print(f'Key: {custom_key}')

# User Editable Region

#decryption = decrypt(encryption, custom_key)
#print(decryption)

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/125.0.0.0 Safari/537.36 Edg/125.0.0.0

Challenge Information:

Learn String Manipulation by Building a Cipher - Step 91

\n needs to go inside a string, please try that

When I add it into the string either like these few examples
print(\n f’Encrypted text: {text}‘) this doesn’t work
print(\nf’Encrypted text: {text}’) this doesn’t work
print( f \n ‘Encrypted text: {text}’) this doesn’t work either.

So I’m just not sure as to where I need to add it in, I tried using the /n to see if that worked but that didn’t either

But when I do print(\nf’Encrypted text: {text}') it tells me that I am getting there.

none of those have \n inside the string.

please identify the string in that print statement before continuing

Yep that was it, completely reading and interpreting it wrong on my part.

Thank you for the help!