Learnyounode won't install

Learnyounode won't install
0.0 0

#1

Can’t even get the thing installed properly in order to fail it! Any thoughts? Also tried Quincy’s version from the video sandsbe:~/workspace $ sudo npm intall learnyounode -g and got the same error.

sandsbe:~/workspace $ npm install -g learnyounode
module.js:487
throw err;
^

Error: Cannot find module 'semver'
    at Function.Module._resolveFilename (module.js:485:15)
    at Function.Module._load (module.js:437:25)
    at Module.require (module.js:513:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/home/ubuntu/.nvm/versions/node/v8.2.1/lib/node_modules/npm/lib/utils/unsupported.js:2:14)
    at Module._compile (module.js:569:30)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:503:32)
    at tryModuleLoad (module.js:466:12)
    at Function.Module._load (module.js:458:3)

#2

Try: sudo apt-get install nodejs-legacy and then try installing learnyounode

Source: https://github.com/workshopper/learnyounode


#3

Thanks for the link and suggestion. Didn’t resolve the issue yet. Here’s what happened:

sandsbe:~/workspace $ sudo apt-get install nodejs-legacy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nodejs-legacy

#4

The issue was I didn’t load the correct template. You’re supposed to load “Blank” and I loaded “nodejs”. Thanks for your help. Lesson: follow Quincy’s instructions!