Loading nix environment doesn't stop

Hello all, I’m trying to work on the replit starter code for the sea level predictor in the data analysis with python course. I am trying to simply run the program, without even modifying any files. Before I run the files, in the console and shell it says the message

Loading nix environment...

If I try to run the program anyways, it is still ‘loading the nix environment’

Does anyone have a solution for this? I’ve tried deleting the project and reinstalling, clearing browser cache, but to no avail, and now i can’t make any progress on the project, as I am not god enough to code the whole thing without a single test run lol

Thanks in advance

Hi, @Pewaukee!
I’m having the same problem with all projects from the Data Analysis with Python, except the Mean-Variance-Standard Deviation Calculator.
I have tried to delete and reinstall it, but the issue remains.
If anyone can help?
Thanks.

that’s weird, seems to be happening to others for random projects, for me the sea level predictor is the only one with issues, all the other ones just worked fine

Right now this can be bypassed by more manual set up of the replit.

  • Start new replit using Python template
  • git clone boilerplate repository
  • Move files from cloned directory to the root folder

Repositories with boilerplates can be found at freeCodeCamp.org · GitHub

ie. for GitHub - freeCodeCamp/boilerplate-demographic-data-analyzer the last two steps can be completed by running in Shell:

git clone https://github.com/freeCodeCamp/boilerplate-demographic-data-analyzer.git
mv boilerplate-demographic-data-analyzer/*.* boilerplate-demographic-data-analyzer/.* .
4 Likes

Thank you so much, @sanity !
I tried this approach in the project demographic data analyzer, and it worked perfectly.
Thanks!

Thank you @sanity this worked for me as well

Hi, could you be a little more specific? I’m very lay in the subject, and didn’t understand what to do.
Thanks in advance.

@Felipe_Antonio_Emer please create new thread with specifics at what point you are stuck. That’s going to be more convenient for all involved parties.

I managed to understand, thanks sanity.

Works like a charm thank you so much !

It works Thank you so much

Hey, I am stuck with the same issue can you please explain the final step(moving files). I am kind of a noob on this matter.
Thank you in advance

@Srikumar please create new thread for convenience. With including specific information at what you are stuck.