Logging Into Local freeCodeCamp installation with Passwordless Authentication

Logging Into Local freeCodeCamp installation with Passwordless Authentication
0

#1

While trying to get setup to contribute to the freeCodeCamp code base I ran into a lot of trouble trying to get logged in now that it’s setup to be done without a password or social authentication. This is what I eventually figured out to get in and start working with a live copy.

  1. Follow the outline @ The Contributor’s Guide to get the repo cloned and all the dependencies installed.

  2. You’ll find yourself here. At this point make sure your browser is pointed at http://localhost:3000 NOT http://localhost:3001!

  1. Click Start coding, then continue with email, enter your email address, and request your magic link :slight_smile: You will be presented with 2 things that are going to make you think your screwed. The button you clicked is going to green out and the server is going to crash! Don’t fret. I got you :smiley:

  1. Restart the server by typing “rs” then hitting “enter” into the shell window that’s running gulp.

  1. Now there are a few ways to do this, but I am using robo3t to get the token from the database that was created when you requested the authentication link from the database. The server crashed because it can’t connect to the AWS account that freeCodeCamp uses to send these emails, so there is no email, but there is a token! :slight_smile:

  1. Take that token and the email you used to sign up back to your browser and goto http://localhost:3000/passwordless-auth/?email=YOUREMAILHERE&token=YOURTOKENHERE

  1. Happy Coding!! :smiley:


#2

Why is this error occuring in the first place? THis is probably because we arent providing any smtp/AWS-SES credentials. the documentation doesnt provide any details as to where we need to provide them.


#3

The problem has been addressed and the local setup instructions have been changed since I posted this. I’m pretty sure everything is documented now. I’m not 100 percent sure though because I haven’t set the site up locally in a minute. Actually, I just checked and they integrated mailhog to solve the issue for developers. It’s all in the contributing document now - https://github.com/freeCodeCamp/freeCodeCamp/blob/staging/CONTRIBUTING.md