Managing Packages with Npm Author Issue

Not working, says // running tests

Unexpected token < in JSON at position 0

// tests completed

link to the project: https://glitch.com/edit/#!/alabaster-argument?path=package.json:1:0

I am not familiar with glitch, could you tell me if adding “author”: “Yayan_Ruhian”,
and leaving everything else the same isnt correct

If it is, then there is another issue. It also says "package.json should have a valid “author” key.

I used the link in the assignment to get to the glitch project.

{
“//1”: “describes your app and its dependencies”,
“//2”: “insert link here”,
“//3”: “updating this file will download and update your packages”,
“name”: “hello-express”,
“author”: “Yayan_Ruhian”,
“version”: “0.0.1”,
“description”: “A simple Node app built on Express, instantly up and running.”,
“main”: “server.js”,
“scripts”: {
“start”: “node server.js”
},
“dependencies”: {
“express”: “^4.16.3”
},
“engines”: {
“node”: “8.x”
},
“repository”: {
“url”: “https://glitch.com/edit/#!/hello-express
},
“license”: “MIT”,
“keywords”: [
“node”,
“glitch”,
“express”
]
}

  1. Log into Glitch using a GitHub login (seems to help).

  2. Click the starter link.

  3. Add the Author, then click the Show button up top next to the project name.

  4. Use that page as the link you submit.

Ah thank you. Now when I press “Show”, it is stuck on starting and does not load.

Hello @JS555 .

For this test you have to use a template which is in the introduction. It is failing because the package is looking for server.js, which is not in your project but it is in the template. Be sure to read instructions carefully!

Good luck and don’t give up!

What I said here still applies, you do seem to have followed the steps correctly. Also, it would be better if you had bumped your old thread again instead of cross posing the same issue in two places.

Oh thank you, it works now. I thought I was using the template, I must have diverged into another template or something when trying to troubleshoot for a while looking at posts.

Appreciate that, it worked.

For sure, thank you. It worked this time. I made sure to reload the template.

Ah, indeed, I forgot I could bump, I haven’t reposted on a forum for a while. Thank you, I will do this if the need arises for another post.