Managing Packages with NPM Error

This is for the first challenge in Back-End Development.

I imported the boilerplate-npm from github to replit.

I could not run it immediately without an error, I believe because the server.js was not loading. I ran “npm i” in the shell which fixed this. I found that advice in a thread here.

After that it worked, but when I copy the link (the correct ‘run’ link) FCC says “package.json should have a valid “author” key”. ← what I entered to FCC.

Thanks for any help.

Replit link: boilerplate-npm - Replit

I just forked your replit. I was able to click Run and open the live url (similar to yours) and it brings up the site which should look like:

Instead with yours I get:

After researching a bit, it seems the SSL certificate got message up when the original replit was created. At this point, I suggest deleting this replit and clicking the link in the first challenge again. Once it is created and you type npm install if needed, you should be able to open the live site and see what I show in the first image. If you see that, then you should be able to proceed with the remaining challenges in the section with no further problems do to

I did as you said but still have the same the same error. I made 3 versions initially to be sure and they all had the same problem so it must be happening on all imports. It loads correctly within replit (image 1) but not in its own tab (image 2).

I’ll just ignore it for now and keep going.

I recorded starting from clicking on the link all the way to seeing it pop up in a new window below.

I actually went down the path as you. I wasted an hour like this. You have to open the webpage and copy the URL and submit that.

We are working on getting the boilerplates fixed due to making some unannounced changes to the way the import works. If everything works as it is supposed to work, all you have to due is click Run. It will perform npm install if it has not been ran and things should just work.

It is working now.

It failed at first, but after 30s it suddenly began working and also worked in the FCC submission. I have repeated it a few more times and it is now working consistently and immediately.

The first time I tried to repeat it, however, I got the following error message initially:
nix error: building nix env: exit status 1
error: executing SQLite statement ‘pragma synchronous = normal’: file is not a database (in ‘/nix/var/nix/db/db.sqlite’)

and the npm install command resulted in 4 different options to select a file (“nodejs-xxx”). I selected randomly and it didn’t work, so just started fresh and subsequent attempts have worked.