Managing Packages with NPM - How to Use package.json, the Core of Any Node.js Project or npm Package - hBKrNtmyLQSXshParCoBz

Tell us what’s happening:
Describe your issue in detail here.
Hi, I’m a bit frustrated because I don’t know how to send the replit solution in the first exercise. I sent this solution which is working fine in browser https://boilerplate-npm-1.danielafunes.repl.co
It’s so easy (just add author in package json), but I don’t wanna continue if in next exercises I wouldn’t be able to test them.
Thanks for any help!

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.114 Safari/537.36

Challenge: Managing Packages with NPM - How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

See my reply to another thread with the same question.

1 Like

Hi, thanks for your response. I’ve tried what you suggested, but the browser shows this:

This site can’t provide a secure connection

boilerplate-npm.danielafunes.repl.co sent an invalid response.

ERR_SSL_PROTOCOL_ERROR

Before that I deleted previous replit, so I started with a new one again following your instructions.

Can you share the link to the project code? My first guess is you are not waiting until it is fully cloned before trying to install and run the app, but that is just a guess.

1 Like

https://replit.com/@DanielaFunes/boilerplate-npm#
please let me know if it works

I think it’s just Replit being weird, it does that sometimes.

Try forking your own project and see if that helps. Otherwise, try using a VPN. You may have to fork the project with the VPN running.

You can also try using Codesandbox or Glitch. Both allow you to import the GitHub repo. Here is a Codesandbox link you can try (githubbox is their domain for quick imports).

https://githubbox.com/freeCodeCamp/boilerplate-npm/
1 Like

How do you fork your own project?

I have seen this happen on at least 5 other projects since last Thursday.

You click the name of the replit at the top left and then the three vertical dots and select fork.

It is pretty random. It’s been like that for a long time. I think people’s location affects it as well (hens the VPN stuff).

1 Like

The weird part is, the preview of the app (showing the https) will work but opening it another tab will cause the error message. Also, you can just use the http version and it will work in the other tab. It must be something related to the SSL certificate that does not completely generate correctly for the custom url created by repl.it.

The iframe also has a URL you can use which usually works (forgot about that).

https://6f5c46a5-06e5-430f-8280-deb7cfcc6990.id.repl.co

Mmm, It could be the vpn stuff because I’m not in US. But I’m not familiarized to vpn.

I’m in the EU and it almost never has happened to me. If I fork your project it works just fine for me. It is random, but I may affect people from different regions (South America, Africa, Asia).

As I said, you can try using CodeSandbox.


Or try using the iframe URL, but that is pretty inconvenient to have to use it and I’m not sure how or when the unique URL changes.

Right-click and Inspect. Remove any path from the end.

Editor iframe:

Should work with the project preview iframe as well:

1 Like

I worked with the user and forking the user’s own project still did not fix it. Nor did forking a version I imported in. For now, the user will try to use the iframe url which seems to work and allowed completion of the first challenge.

1 Like

Genius, thanks! I’ve been all day trying to fix it. This is a great community <3