Mario Database Gitpod Typing Issues

This issue seems to be specific to the Mario Database project in Gitpod. I didn’t experience this in the previous gitpod CLI project. Whenever I am typing in the Mario database project CLI it will randomly jump ahead several spaces as if I had hit tab several times. I have been extra careful thinking that some combination of keys that I was hitting was causing this. However; after ensuring that I wasn’t hitting the touchpad, and using caps lock instead of shift etc. this still continues to occur no matter how carefully I enter the commands. I am almost certain that this isn’t related to how I am typing in the command since this didn’t occur on the previous project.

I have tried multiple OS, browsers, and laptops/desktops. This continues to occur, and is very frustrating because when this occurs, even if I backspace and correct what I am typing, whatever the last thing I entered was before this happened, is what will be entered.

For example, if I entered

ALTER TABLE secon CURSOR JUMPS OVER HERE

and then backspace back to where I left off and then enter:

ALTER TABLE second_table ADD COLUMN column1; (then press enter)
it will still think I entered
ALTER TABLE secon

This gets very frustrating because it continues to occur every few commands that I enter and is keeping me from progressing in the exercise. I’m surprised that there isn’t any other posts about this considering that I am experiencing it on Linux & Mac in Firefox and also in Safari on Mac. Any ideas on how to fix this?

Some images of what I am referring to:


As you can see the text cursor jumps forward while I am typing

2
Now I back spaced and entered the command exactly as it should have been, but it acts as if I had entered the text as it was when the cursor jumped forward, as if I never corrected it.


As you can see here I entered the exact same command twice, and got a different result because of this issue.

I have tried this on:

MacOS iMac M1: Firefox & Safari
Manjaro Linux Laptop: Firefox & Chromium
Windows 10 Laptop: Edge & Firefox (Fresh install with no add-ons)

Seeing the same issue across all platforms and browsers.

I have exactly the same issues and I keep losing my progress

Does anyone have any idea on how to fix this?