Medical Data Visualizer - Python error

I have already submited the first two projects of the Data Analysis with Python course but this time when I tried to run my project on replit it shows the following error:

Updating dependencies
Resolving dependencies…

The current project’s Python requirement (>=3.7,<4.0) is not compatible with some of the required packages Python requirement:

  • matplotlib requires Python >=3.9, so it will not be satisfied for Python >=3.7,<3.9

Because no versions of matplotlib match >3.8.2,<4.0.0
and matplotlib (3.8.2) requires Python >=3.9, matplotlib is forbidden.
So, because root depends on matplotlib (^3.8.2), version solving failed.

I have tried updating matplotlib but it still shows the same error.
What can I do to fix this?

Did you get a solution to this problem?

Hello,
I found this post with a similar problem andthe solution proposed works for me: