Just finished the pomodoro clock and would love your comments not so much about looks, but more about the way it is coded and what to improve in terms of solutions and approach towards coding itself.
Oh my that sound might give someone a heart attack
Maybe you can rename
curState to something like
isTicking. It’s easier to figure out what
if (pomoClock.isTicking) means.
Adding the sound was actually my reward for completing the task, I’ll probably replace it later with something more subtle
Thank you for the curState idea, which would make more sense than what is being used now. since isTicking directly answers the question with true or false it seems a much better idea than curState which can not be said to do the same thing. Changed it to isRunning.