MongoDB and Mongoose - Install and Set Up Mongoose

Tell us what’s happening:

I can’t validate this step despite my package.json file looks correct.

I use Glitch with this content :

{
“name”: “fcc-learn-node-with-express”,
“version”: “0.1.0”,
“dependencies”: {
“mongoose”: “^5.11.15”,
“body-parser”: “^1.20.2”,
“cookie-parser”: “^1.4.6”,
“dotenv”: “^16.4.5”,
“express”: “^4.19.2”,
“fcc-express-bground”: “GitHub - freeCodeCamp/fcc-express-bground-pkg: Backend boilerplate node express - package test
}…

###Your project link(s)

solution: Glitch :・゚✧

Your browser information:

User Agent is: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/125.0.0.0 Safari/537.36

Challenge Information:

MongoDB and Mongoose - Install and Set Up Mongoose

Hello and welcome, Its really difficult to know whats going on when the JSON is all good but it tells you there is nothing there, also runnung from Glitch says I’ve hit a Glitch. :grinning:
If this scenario is the same reinstall using npm init and install mongoose with npm etc… again dont know how this works with glitch as apposed to VScode with node installed.

You are not using the correct boilerplate.

https://github.com/freeCodeCamp/boilerplate-mongomongoose/

The name in the package.json should be "name": "fcc-mongo-mongoose-challenges"


On Glitch, you may also have to run enable-npm in the terminal.