MongoDB lessons "Could not find node 4.4.5, using 10"

I cannot figure out how to solve this error that Glitch is giving me:

I have seen a few others ask a similar question but have not seen any responses that work for me.

Help?

PS - Node and Express were working the other day for earlier lessons, but have since stopped working.

My Glitch Link

I believe the error is being caused in your package.json.

mongodb: ^4.0.10 doesn’t work because the latest version of mongodb on npm is 3.2.7.

Change that and I believe it will work.

I’m not exactly sure why that caused the error message it did, my best guess is that the error for mongodb stopped the program from loading express, without showing you the error? I’m not sure.

Try:

  "dependencies": {
    "express": "^4.16.4",
    "body-parser": "^1.19.0",
    "mongoose": "^4.3.0",
    "mongodb": "^3.2.6"
  },

Thanks guys! Randell’s suggestion did the trick.