My code looks right but won’t submit?

This step looked fairly simple, just one small change but it says its incorrect. Please help

Step 49 of the Color Markers in CSS says to change background-color to background which i did but it says it’s wrong. I even tried a couple other browsers, restarting my device, etc. I don’t have dark mode and i just started so few changes had been made.

  **Your code so far**
/* file: index.html */
<!DOCTYPE html>
<html>
<head>
  <meta charset="utf-8">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <title>Colored Markers</title>
  <link rel="stylesheet" type="text/css" href="styles.css">
</head>
<body>
  <h1>CSS Color Markers</h1>
  <div class="container">
    <div class="marker red">
    </div>
    <div class="marker green">
    </div>
    <div class="marker blue">
    </div>
  </div>
</body>
</html>
/* file: styles.css */
h1 {
text-align: center;
}

.container {
background-color: rgb(255, 255, 255);
padding: 10px 0;
}

.marker {
width: 200px;
height: 25px;
margin: 10px auto;
}

*.red {*
*background: rgb(255, 0, 0);*
*}*

.green {
background-color: #007F00;
}

.blue {
background-color: hsl(240, 100%, 50%);
}

  **Your browser information:**

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.4 Safari/605.1.15

Challenge: Step 49

Link to the challenge:

You dont need the many * there in the .red {...}

Those asterisks are not actually in the original code, they are simply there to highlight the section I was asking about

Oh, ok.

I tried your code with two spaces before the background word and worked.
Can you try it?

Tried it but still no results, not sure what’s up with it

What the error says?

Just says, “Your .red CSS rule should have a background property with the value rgb(255, 0, 0)” which is what I have

This is very strange.
I have copied and pasted your code (the .red part only) and it passed.

Maybe you should report to the staff?

Ya it seems like an internal glitch of some kind. I will try to reset my device and update the browser. thanks for your help though

1 Like

Yes, do that. I’m using the updated Edge here.
Let me know if that works.

Good luck.

Thanks so much! I got it to work. I switched devices (apple—Microsoft) and it submitted. I’ll keep this in mind for future issues

There is the issue. Apple has some problem in their adherence to standards that is breaking this challenge. There are a couple f challenges like this.