My green hamburger menu disappeared

Tell us what’s happening:
So I did free code camp in Safari, but am doing cope pen in Chrome. Someone was able to help me get my green hamburger menu up (it was not there at beginning). I have not worked on this in a few days and now again my green hamburger menu is missing. I went back to try and check and change my cookies settings, but I don’t think I did the correct change as the hamburger menu is still missing. I cannot find the original post to refer back to as that may take care of it. Thanks and not sure why it reverted back to possibly blocking cookies?

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1 Safari/605.1.15.

Challenge: Build a Tribute Page

Link to the challenge:


Maybe you didn’t save the pen… you may have used a different CodePen account or just didn’t login?

So I did save it, but did not log out and back in, just click on the circle to reload…is this not enough?

Typo…this is what you want;

<script src=""></script>

You put a closing bracket (>) right after script so it doesn’t see the source attribute

Thanks - that did add back the “Run Test” box, but something is still missing as I cannot run the tests. It say “load test” and there is nothing to load.

have you selected the project from the drop down menu?

Good question, but yes.

what web browser are you using?
the test suite may not work if you do not use google chrome

I am using Chrome, but strange thing is I initially had this problem, somehow it got fixed, as I was missing the hamburger menu in Chrome then I had the “load tests” button. I went back and looked through previous replies, but cannot find this. It was fixed and now it is not. I went back into my Chrome blocked cookies settings but really not sure how this has happened again. Also, what is the best way to find replies to my posts on issues? I find it I click off and away I can find many things in your forum, but not necessarily an emailed response. I used to get it in my email and then clicked to answer, but today that is not happening either. Strange.

Sorry, I thought you had a different menu, not realizing you were talking about the tests menu :sweat_smile:.

After adding the fix mentioned by @Roma the project works and the tests are run fine, at least on Firefox.

Noticing I have this at the bottom of my page

#mocha div missing, add it to your document

#mocha div missing, add it to your document

#mocha div missing, add it to your document

#mocha div missing, add it to your document

#mocha div missing, add it to your document

#mocha div missing, add it to your document

Could these be the issue?

Strange, this fix allowed the hamburger menu to appear and the box of buttons, but the bottom button remains on “load Page” and therefore my tests do not run. I am in chrome.

Do you happen to have any plugins enabled? They may intervene on the page and your app, so, disable all of them and try again.

Also, could you share a screenshot? It’s weird, I tested this on Chrome and works fine too:



If you search the forum for “mocha div missing” you will find many posts and many solutions. One of them is that you have to add to the list of allowed third-party website cookies.

Thank you thank you but I got it working by adding the,, and to my allow cookies - in Chrome.

1 Like