Need Help With Code Ally Loading Issues: Learn Bash Scripting by Building Five Programs - Build Five Programs

The Problem

I’ve been trying to load back into this course after stopping in the middle a day ago. At first the VM kept freezing up on the white screen at loading virtual server but after a dozen or so page refreshes it started loading in properly. However, now once the server loads Code Road is nowhere to be found.

What I've Tried

I followed the standard troubleshooting instructions to manually reload Code Road:

went to view >> Command Palette.

Usually Code Road is right at the very top, but this time it wasn't which was weird, so I typed Code Road into the source bar and it says no matching commands.

I tried searching several variations:
  • Code Road

  • CodeRoad

  • Road

  • Code

The last one pulled up some options but nothing to do with Code Road.


I’ve refreshed the page and restarted the course half a dozen times, it doesn’t freeze at virtual server anymore, just refuses to load Code Road and searching yields the same results mentioned earlier every time.


At a loss as to how to proceed.


Attaching screenshots showing the program as it loads in and then the result of searching code road in the command palette search bar. Any suggestions?

Thanks for your time and any advice you can share.

Screen after initially loading in with Code Road instructions not loading:

Screen while searching for Code Road to load manually under command palette:

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/111.0.0.0 Safari/537.36

Challenge: {{challengeTitle}} Learn Bash Scripting by Building Five Programs - Build Five Programs

Link to the challenge:

Okay so I decided to keep plugging at it and thought maybe search extensions for CodeRoad?

when I did it popped up but says its not installed?

here’s a screenshot:

Went ahead and installed it.

Used Ctrl + R to refresh the screen.

Restarted the project.

Code Road still didn’t autoload, but I was able to find it via view >> command palette and searching CodeRoad…but

and that’s a big ol’ but no I get this:

Think I’m gonna stop fiddling with it before I break it even worse.

I’m almost finished with this part of the course and really, really, really, really don’t want to have to restart this section by deleting my data from CodeAlly, but I get the feeling that’s where this is heading.

Sigh.

Again any suggestions extremely appreciated.

Thanks.

Refreshed the project again.

Manually started CodeRoad.

It worked this time, but all my progress is gone.

Closed the tab.

Opened codeally.

Clicked run code to load from my saved data.

No dice.

All my progress is gone.

So it’s working now but what happened to my progress?

And what caused the issue to begin with?

With Building-Five-Projects, this isn’t such a big deal, but if this had happened while I was working on that Celestial Bodies Database, I’d have been super upset. That was a ton of work to just potentially lose.

Any way to prevent this from happening again?

Was it something I did wrong by just closing the tab after I hit a checkpoint? Everything reloaded fine when I did that during the Mario Database and when working on the Celestial Bodies Database.

Thanks.

Hey.
The exact same thing happened to me during the Build a Student Database Part 2 lesson.
I tried everything but ended up just resetting and restarting the course after completing around 80%… I managed to complete it all the way the second time around, but the same thing happened before the course was marked complete so Im back to square one again. Not sure I have it in me to do all that a 3rd time., hoping someone from FCC see’s your post and can help out. Good luck!

try soft reseting the project

Thanks for the advice, I did that a couple times before posting here.

Oh wow I’m so sorry that happened to you. Don’t let it discourage you, I just finished that section last night so I know how tedious it is, but just think of it as extra practice and by the third time through you’ll have SQL down solid. Don’t give up!

The course is still in beta so there’s bound to be bugs and kinks to work through. I definitely love the interactivity a lot more than the walls of text I had to slog through in the Javascript course though so for me the bugginess is worth it.

I did notice that everything with the program went back to working normally after I deleted my code progress on Code Ally so I can’t help but wonder if my save data didn’t somehow get corrupted?

It has made me a little paranoid though so the whole way through Student Database I and II I never closed the program :sweat: :grimacing:

I’m glad you got your issue figured out.
Do you mind explaining to me how you
“deleted my code progress on Code Ally”?

I’m having the same issue but I’m not sure how you delete your your code progress ?

You can log on to the CodeAlly site (which you will have registered with when you started these courses). Then find the ‘Cloud IDE’ tab and it will show you a list of all of the projects you have been working on. If you delete a project and then go back to FCC and start the course up again, you’ll be starting entirely afresh.