Need help with technical doc page. Thanks!

On #4 of the contenting I got an error because im supposed to have underscores instead of spaces, https://codepen.io/GoodNGo/pen/wvJqGbY. I got some help from a friend and added some code at the bottom to give the text underscores and its still an error. can you help me with this?

I have created a new topic for you.

When you are working on a new project you need to create a new topic.

For user story 4, you will need to use the text inside each of the header tags

for exmaple:
<header>What is Lorem Ipsum?</header>

and create an id in the section tag with the header text. Use underscores for spaces.

For example:

  <section id="What_is_Lorem_Ipsum?" class="main-section">
      <header>What is Lorem Ipsum?</header>

You need to do that for every header and section

I did this for the headers and I went back from 8/16 to 7/16. and do I have to create the section id? all of my section text has underscores https://codepen.io/GoodNGo/pen/wvJqGbY

Why did you create two opening section elements?

 <section class="main-section">
       <section id="What_is_Lorem_Ipsum?">

You now have syntax errors because there are missing end tags.

Please look carefully at the example I showed you

  <section id="What_is_Lorem_Ipsum?" class="main-section">
      <header>What is Lorem Ipsum?</header>

Make sense?

1 Like

I’m failing user story #6 even though I have 5 code elements https://codepen.io/GoodNGo/pen/wvJqGbY

Read the error message more carefully.

There are not at least 5 elements throughout all of the elements with the class of ‘main-section’

does this mean each main-section class should have 5 code elements? I only ask because it specified that it should be 5 total, not each. " 6. The .main-section elements should contain at least 5 elements total (not each)."

I need help with number 13 in content. what does this mean? " 13. When I click on a navbar element, the page should navigate to the corresponding section of the “main-doc” element (e.g. If I click on a “nav-link” element that contains the text “Hello world”, the page navigates to a element that has that id and contains the corresponding ."

You a missing something at the end of your href value in the nav link. It is supposed to be What is Lorem Ipsum?

I don’t know, all of them have the closing <a> tag. https://codepen.io/GoodNGo/pen/wvJqGbY

You wrote this but it is incorrect


<a class="nav-link" href="#What_is_Lorem_Ipsum>"><li>W

Look very carefully at what I wrote in my previous reply.

The correct answer is What_is_Lorem_Ipsum?

You wrote What_is_Lorem_Ipsum>

fixed it but its still giving me an error.

Look very carefully at my correct answer and your incorrect answer

You wrote What_is_Lorem_Ipsum?>

Paying attention to detail is important for becoming a developer :grinning:

2 Likes

on this pen https://codepen.io/GoodNGo/pen/qBrXeRM I keep getting an application error, and I cant save my work. can you help?

If you are getting an application error then you will deal with codepen directly.
I would look for some sort of support/ help area and reach out to them that way.

You can also use an alternative like codesandbox if the issue continues.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.