New Responsive Web Design Step:28


I need help in regards to adding the attribute of ‘min’ of 13 in my code. For some reason I am getting an error and it gives me the hint of " You should give the input a min attribute with a value of 13 ." I’m not sure what exactly I am doing wrong because I did receive the warning to place a value equal to or greater than 13 when I placed a lower number when testing it myself. Please direct me in the right direction, I would greatly appreciate it!

   **Your code so far**
/* file: index.html */
<!DOCTYPE html>
   <title>Registration Form</title>
	  <link rel="stylesheet" type="text/css" href="styles.css" />
   <h1>Registration Form</h1>
   <p>Please fill out this form with the required information</p>
   <form action=''>
       <label>Enter Your First Name: <input type="text" required /></label>
       <label>Enter Your Last Name: <input type="text" required /></label>
       <label>Enter Your Email: <input type="email" required /></label>
       <label>Create a New Password: <input type="password" pattern="[a-z0-5]{8,}" required /></label>
       <label><input type="radio" name="account-type" /> Personal Account</label>
       <label><input type="radio" name="account-type" /> Business Account</label>
         <input type="checkbox" required /> I accept the <a href="">terms and conditions</a>
       <label>Upload a profile picture: <input type="file"/></label>
<label>Input your age (years): <input type="number" min="13" max="120"/></label>
     <input type="submit" value="Submit" />
/* file: styles.css */
body {
 width: 100%;
 height: 100vh;
 margin: 0;
 background-color: #1b1b32;
	color: #f5f6f7;

label {
	display: block;
	margin: 0.5rem 0;

   **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.63 Safari/537.36

Challenge: Step 28

Link to the challenge:

Looks correct to me, not sure why it’s not working. Here’s what I have:

Input your age (years):

^try this?^

that’s really odd. when I tried pasting your code into my editor for that step, it worked perfectly fine, so I don’t think there’s anything wrong with it.

have you tried reloading? it might be a glitch with freeCodeCamp itself

I actually refreshed it prior and it still wouldn’t accept it. I waited till today to try again and it finally worked! thank you for the reassurance and advice! I appreciate it!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.