Not able to complete the task - Learn Bash Scripting by Building Five Programs - Build Five Programs

Tell us what’s happening:
Describe your issue in detail here.
I am not able to complete the task even after entering the command into the terminal [[ 4 -ge 5 ]]. I did the reset and exit the terminal but it still not working. Please help.
Your code so far
[[ 4 -ge 5 ]]

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0

Challenge: Learn Bash Scripting by Building Five Programs - Build Five Programs

Link to the challenge:

Take a screen shot of what you have in the file. up to this point is well completed. I think it’s about the loss of the permission.
You have to repeat the command to ask for permission to run executable files every time because it is lost often.

1 Like

I have tried but it still didn’t work. I am stuck at this task where you have to enter [[ 4 -ge 5 ]] into the bash terminal and check the result using something like echo $?.

Add " echo $* " at the bottom of the file
Add “./” in the terminal. It is to see if you have something printed or not.
With the “ls - l” command, you can see what permissions you have in this tab. The fact that it gives you the result “-rwsr-xr-x” is very good.
Normally after the 3 commands in the terminal:
“chmod +x”
“ls - l”
you should move on from this point.
If not, I suggest to restart the project.

1 Like

Thank you, I restarted the project from the beginning and it solves the problem.