Not letting me progress when colors are used in code

Tell us what’s happening:

  **Your code so far**

<style>
.red-text {
  color: #FF0000;
}
.green-text {
  color: #00FF00;
}
.dodger-blue-text {
  color: #1E90FF;
}
.orange-text {
  color: #FFA500;
}
</style>

<h1 class="red-text">I am red!</h1>

<h1 class="green-text">I am green!</h1>

<h1 class="dodger-blue-text">I am dodger blue!</h1>

<h1 class="orange-text">I am orange!</h1>
  **Your browser information:**

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 11_2_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.90 Safari/537.36.

Challenge: Use Hex Code to Mix Colors

Link to the challenge:

This is the error I am getting. It happens any time there is a color change prompt. I have gotten around this issue by just moving forward manually in the curriculum, but I am unsure why this keeps happening.

Did you try using inline styling instead of <style></style> ?? ie :

<h1 class="red-text" style="color: ....">I am red!</h1>

From a quick overview i don’t see what’s wrong, unless it’s expecting you to use the styling inline as i said

1 Like

Are you using a dark-mode extension? Those extensions work by changing your CSS, which interferes with the test suite.
With the CSS challenges it is important to disable all browser extensions that modify your CSS, such as dark mode extensions. freeCodeCamp does have a native dark mode you can enable in your settings.

1 Like

@ZacharyCel, just an FYI that that’s not what the lesson is asking for.

1 Like

Been a while since i did that one , just shot my shot in the dark i guess , otherwise couldn’t see what’s wrong !
Didin’t intend to misslead or confuse sorry :sweat_smile:

1 Like

I am, and that was my first assumption and it does the same thing when I remove the extension and reboot chrome.

1 Like

Ope! You were correct I had turned off but not removed the darkmode extension. I thought I had removed previously. Thank you!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.