Problem formatting a USB Drive to FAT32 on Windows 10 - any suggestions?

Hi – I found your site while looking for a way to format a USB drive to FAT32, using Windows 10. I have a 256GB drive, so I followed Kris Koishigawa’s guidance on using Powershell to do this in How to Format a USB Drive to FAT32 on Windows 10.

The process appeared to be working OK, but on reaching 100% reported “The volume is too big for FAT32. Format failed”, although Kris’s guidance says it should work on “a USB drive of any size”. The drive itself worked fine when formatted to exFAT, but I need to reformat it for compatibility with another device

I’m not a Twitter user so can’t follow Kris’s suggestion to contact him via Tweet. Can anyone on the forum suggest where I might go from here? I would be grateful for any thoughts.

Thanks in advance,

Yosser

I have no idea, maybe @scissorsneedfoodtoo Kris himself…

I would suggest using a tool like Rufus or FAT32 Format (According to the Rufus FAQ it uses the FAT32 Format code under the covers). It’s just safer and should be faster as well.


It might have something to do with how the drive is currently formatted, you can try preparing it using DISKPART. Just be careful you don’t wipe the wrong drive.

I’m pretty sure there are other limitations like some upper limit (2TB or something like that) and I think a label length and character set limit (11 characters and no weird symbols).

Yeah, that’d be a good idea. I’ve got a couple of other things to try first, but if they don’t work I’ll do that. Thanks for the suggestion and the link :slight_smile:

Thanks lasjorg - Rufus worked a treat. I’ve no idea why PowerShell didn’t, but I’m up and running now so I don’t really care either. Thanks again

Hi @Yosser, thanks for reaching out about this, and thanks @lasjorg and @ilenia for replying.

Glad to hear that Rufus worked for you. I also mentioned it Rufus in the article, though if I remember correctly, I used a 64GB flash drive at the time for testing, not a larger 256GB one.

I’ll see if I have a larger flash drive around to test the Powershell method with and will update the article if I run into the same issue.

Hi @scissorsneedfoodtoo , and thanks for getting in touch. I did see your mention of Rufus, but given that I’d previously formatted an identical (afaik) USB drive using Powershell I thought I do it that way again (even tho’ I had to search again for how to do it - my computer has far more memory than I do…) rather than download yet another program. As it was, Rufus was no trouble at all - quick and easy to download and run, and far quicker than Powershell at the formatting, as you said. Thanks again for your original guidance, and for getting back to me. Yos.