Problem with: Apply a Style Until a Condition is Met with @while

Problem with: Apply a Style Until a Condition is Met with @while
0.0 0

#1

Hi! Hi think I’m doing well. At least I can see every class with the correct font-sizes, but the running test tells me that it’s not OK. This is my code:


<style type='text/sass'>
  
  
  $x : 1; @while $x < 11 {
    .text-#{$x} { font-size: 5px * $x;} 
    $x: $x + 1;
    }
  
</style>

<p class="text-1">Hello</p>
<p class="text-2">Hello</p>
<p class="text-3">Hello</p>
<p class="text-4">Hello</p>
<p class="text-5">Hello</p>
<p class="text-6">Hello</p>
<p class="text-7">Hello</p>
<p class="text-8">Hello</p>
<p class="text-9">Hello</p>
<p class="text-10">Hello</p>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/front-end-libraries/sass/apply-a-style-until-a-condition-is-met-with-while/


#2

Hey, just try to remove the space preceding the colon at ‘$x : 1’.
If it still doesn’t work, keep a copy of your code,
then click on ‘Reset All Code’ and then type/paste code again… :slight_smile:


#3

Hi! Did it, but still doesn’t working. What a mistery! :slight_smile:
Thanks @phoenixabhishek


#4

Hello^^
You can check this post: GitHub - Freecodecamp issues: Sass - Apply a style (…) ( substantially it suggest you to use Firefox because Chrome has few problem with this challenge )