Problem with FCC Test CDN

I am using the CDN link to test my project locally on my machine, I add it after the </body> tag. when I opened the inspector (I am using firefox developer edition), it shows Uncaught SyntaxError: illegal character on bundle.js line 1 column 1.
my page setup is like this :

<!DOCTYPE html>
     <!-- css link + google fonts + metrial icons css -->
      <!-- page markup -->
      <script src=""></script>

Are you running the test against some code, or is that all you have, and it just gives you that error when you look in the console?

I don’t see that error with the code you have posted, but if you want to test locally make sure you are running the code using a server. You can use something like the Live Server extension in VS Code. Otherwise, some tests may fail.

I am using vs code with live server, I have no js script in the document, but the fcc test script


Capture d’écran 2020-11-12 175328


does the sameSite header is the problem ?

No, it’s not the cookies warning.

I can’t reproduce the error and the fact that the error is on line 1 column 1 seems a bit odd. Can you expand the error so we can see all of it?

  • Do you have any extensions installed in the browser that might be causing this?

  • Does it work in Chrome?

@lasjorg I tried also chrome, same Uncaught SyntaxError error happened

the weird thing, I created an empty HTML file and included the script and it worked fine.
here is my project link:

Hello there,

What happens if you include defer in the script tag?

Hmm, don’t think I have seen this before.

The HTML file seems to be corrupted. Create a new HTML file and copy-paste the code into it, then delete the old and rename the new one as needed. Now try running it again.

Edit: Hopefully it was caused by a network error or just some fluke and is not a sign of a hard disk issue.

@lasjorg i’ve copied the file content to a new HTML file and it works fine. so clearly, the original file was corrupted. thank you