Product Landing Page - Build a Product Landing Page

Tell us what’s happening:

Stuck on “Each .nav-link element should link to a corresponding element on the landing page (has an href with a value of another element’s id. e.g. #footer)” been stuck for 3 hours with no different being made. plz help

Your code so far

<!-- file: index.html -->
<!DOCTYPE html>
<html lang="en">
 <head>
  <meta charset="UTF-8">
  <title>Mobi-fax App</title>
  <link href="styles.css" rel="stylesheet" />
  </head>
  <body>
    <div id="page-wrapper">
    <header class="header"
    id="header">Mobifax
    <div class="logo">
      <img id="header-img" src="https://images.app.goo.gl/bDaMHKbc1Dr6RVZD6" alt="phone icon">
      </div
      </header>
      <header class="nav-top">
  <nav id="nav-bar">
      <div class="nav-top">
      <ul>
        <li><a href="#features" class="nav-link">Features</a></li>
        <li><a href="#how-it-works" class="nav-link">How it Works</a></li>
        <li><a href="#pricing" class="nav-link">Pricing</a></li>
        </ul>
        </header>
    </body
    <body>
      <main>
        <section id="hero">
          <h2 class="Email">Please Enter Your Email</h2>
        <form id="form" action="https://www.freecodecamp.com/email-submit">
        <input name="email" id="email" type="email" placeholder="Enter Your Email Address" class="email" required>
<input type="submit" id="submit" value="Sign up" class="btn">
</form>
</section>
<div class="container">
 <section id="features">
   <div class="grid">
   <div class="desc">
     <h2 class="commun">Communication</h2>
   <p class="desc1">
        Actively Communicationing occurences and concerns to appropriate staff faster and more efficiently with the ability to take photos within the O.R room.</p>
        </div>
  </section
 <section id="how-it-works">
  <h2 class="how-it-works">How it Works</h2>
  <p class="desc1">
    Taking an initial Picture of whatever the situation is at hand, selecting occurence or concern and who/where you intend to send it with a brief description of the problem.
  </p>
 </section>
 <section id="pricing">
   <iframe id="video" height="315" src="https://www.youtube.com/watch?v=vw0SbxDF0h4" frameborder="0" allowfullscreen>
   #document (https://www.youtube.com/watch?v=vw0SbxDF0h4)
   </iframe>
 </section>
        </main>
      </body>
  </html>
/* file: styles.css */
* {
  margin: 0;
  padding: 0;
  box-sizing: border-box;
}

body {
  background-color: orange;
  font-family: 'Lato', sans-serif;
}
.nav-top{
position: fixed;
width: 100%;
top: 0px;
left: 0px;
margin-left: 300px;
}
#page-wrapper {
  position: relative;
}
.nav-top{
  
}
li {
  list-style: none;
}
.header{
  Font-size: 50px;
}
.logo{
   height: 100;
    style: max-width: 120px;background-position: top left;
}
.nav-link {
  font-size: 23px;
  padding-top: 10px;
  text-decoration: none;
  display: flex;
  justify-content: end;
  display: inline;
}
.nav{
  position: fixed;
  top: 0;
  right: 0;
}
#hero {display: flex;
  flex-direction: column;
  align-items: center;
  justify-content: center;
  text-align: center;
  height: 200px;
  margin-top: 50px; 

}
#hero > .email{
  margin-bottom: 20px;
  word-wrap: break-word;
  font-size: 25px;
}
#hero input[type='email']{
 max-width: 275px;
  width: 100%;
  padding: 5px;
}
#hero input[type='submit']{
   max-width: 150px;
  width: 100%;
  height: 30px;
  margin: 15px 0;
  border: 0;
  background-color:rgb(147, 236, 236);
}
}
.btn {
  padding: 0 20px;
  height: 40px;
  font-size: 1em;
  font-weight: 900;
  text-transform: uppercase;
  border: 3px black solid;
  border-radius: 2px;
  background: rgb(147, 236, 236);
  cursor: pointer;
  margin-left: 75px;
  margin-top: 50px;
  
}
.desc{
  font-size: 25px;
}
.desc1{
  font-size: 20;
}
.How-it-Works{
  font-size: 50px;
}
h2{
  font-size: 50px;
}
@media (max-width: 650px) {
  nav {
    margin-top: 10px;
    width: 100%;
    display: flex;
    flex-direction: column;
    align-items: center;
    text-align: center;
    padding: 0 50px;
  }

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/123.0.0.0 Safari/537.36

Challenge Information:

Product Landing Page - Build a Product Landing Page

I figured it out, had to use divs instead of section elements