Project 4, not passing the Log array Date must be a string, but all input matches mock project

Tell us what’s happening:
Hello, I am having a hard time determining why my test case is not passing, I’ve done typeof user.log[i].date and it returns a string for what I’m passing, mongoose is set up for it to be a string.

I’ve dropped the collection and remade it multiple times and I’m truly stumped. I’ve read topics about this in the form about how they were only checking that the req.body.date is equal to “”, but what I’m doing is If (req.body.date) though I’ve tried to do it the way other people have mentioned and I get the same results.

Your project link(s)

[https://replit.com/@RobertBridges/boilerplate-project-exercisetracker#.replit](https://Replit project url)

if it’s easier to use GitHub I have it there too.

First time I’ve been stumped like this on this project and it’s dragging me down, any assistance would be greatly appreciated. Thank you!

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36

Please disregard this post, I was thinking maybe time zones were messing with this, and I ran it early this morning and everything went through. Strange.

Thanks guys!