Python/Pandas Version Incompatibility (Sea Level Predictor)

Hi, when I first import the Replit code for the Sea Level Predictor assignment from GitHub, I get this runtime error:

The current project’s Python requirement (<=3.8, <4.0) is not compatible with some of the required packages Python requirement:

  • numpy requires Python >=3.9, so it will not be satisfied for Python >=3.8,<3.9

There’s more, but I’m not sure how to copy and paste from the replit console.

However, when I update my Python version to 3.9 in pyproject.toml and try again, I run into a different error while pandas is being installed. Again, not sure how to copy and paste all of it but it ends with:

Note: This error originates from the build backend, and is likely not a problem with poetry but with pandas (0.25.3) not supporting PEP 517 builds. You can verify this by running ‘pip wheel --use pep517 “pandas (==0.25.3)”’.

Then it stalls out while installing scipy. Any advice on how to make heads or tails of this? I’m eager to start the project, thanks!

Try deleting pyproject.toml (may need to show hidden files) and install anything missing from the Shell command prompt like this:

pip install numpy (if you get an error that there’s no numpy module)