Quality Assurance and Testing with Chai - Test if a Variable or Function is Defined

when i pres the " i’ve completed this challenge" button and runs the test , it gets timed out , i’ve tried so many solutions that i found at google but no one worked. i have seen the console there’s 25 issues. can anyone help me please.

solution: quality-assurance-testing-with-chai - Replit

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/108.0.0.0 Safari/537.36

Challenge: Quality Assurance and Testing with Chai - Test if a Variable or Function is Defined

Link to the challenge:

the solution is,after only doing the code for the challenge in the replit run it and see if your code passes in the console and if it does stop it,copy the live url link and paste it in the FCC and run the tests.the reason is as you can see in the browser output in the replit when you run the code it loads the initial template provided by FCC but suddenly crushes and keeps saying Replit waking up .
so,doing what i mentioned above does is when you run the test on FCC first by stoping it in replit it prompts the replit to run again and pass the test before the replit crashes again.

Thank you so much i have tried this it worked for once then i have the same problem for the next challenge even tho I’m doing the same method by running it on replit and when it’s true i stop it then copy the live url and paste it in fcc and run the test.

ya,running replit is very annoying.what you have to do is run the test again and agian using the same method.
but to avoid such think i suggest running the challenges locally