Quality Assurance - Headless Browser First Challenge not passing even with code from guide

I’ve tried with my code and when it didn’t worked I’ve copied the code from the guide directly but it is still not passing.
What could be the reason? I do not have assert.fail() anywhere.

My glitch code: https://glitch.com/edit/#!/curved-napkin

This is the result I get after running the tests:

expected undefined to equal 'passed'
Cannot read property '0' of undefined
Cannot read property '1' of undefined
Cannot read property '2' of undefined
Cannot read property '3' of undefined

can you link the challenge please?

https://learn.freecodecamp.org/information-security-and-quality-assurance/quality-assurance-and-testing-with-chai/run-functional-tests-using-a-headless-browser

I just ran into the same issue, though I’m only getting the “expected undefined to equal ‘passed’” message and not any of the “Cannot read property” messages.

I believe the problem is that the freeCodeCamp challenge tests expect you to use the browser.assert.element function, but with the arguments of the browser.assert.elements function. The former takes only one argument, while the latter takes two arguments. As far as I can tell, it is not currently possible to complete the challenge as intended.

Note that this also affects the next challenge, Run Functional Tests using a Headless Browser II.

Are you sure it isn’t just the wrong URL for the Browser.site property?

Browser.site = 'https://curved-napkin.glitch.me';

If I remix the project and use the correct URL the test passes for me.

I’m using the right URL in my project:

You are getting a different message though.

expected 'failed' to equal 'passed'

I didn’t really look at your code yet but you may have a different issue in the code.

Ah, good point. Should I open a separate thread?

Yes, that’s probably better.