Quality Assurance Projects - Personal Library

Tell us what’s happening:
Describe your issue in detail here.
I’m trying to solve this challenge but it seems that i’m missing something here
at this test " * Failed: You can send a GET request to /api/books/{_id} to retrieve a single object of a book containing the properties title, _id, and a comments array (empty array if no comments present). If no book is found, return the string no book exists."
what the call that i should be expicting ?
is it “/api/books/?id=bookid” or “api/books/id=bookid” ?
when i try to send a get request to “/api/books/?id=bookid” nothing happens at all i don’t even get a log of bookid,
however when i send a get request to “api/books/id=bookid” i get the bookid from req.params.id as “id=randomId” instead of just getting the id, so i tried slicing it to get the id only but that does not work ,
what am I missing here , please let me know what’s wrong with my approach.

Your project link(s)

solution: boilerplate-project-library - Replit

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/112.0

Challenge: Quality Assurance Projects - Personal Library

Link to the challenge:

I’m not sure (I can look) but the test might be expecting a 200 and not a 404 for the no book exists response (as odd as that sounds).

Edit: no, that is not it.

never mind i figured it out , for some reason i keep mixing up params with query

i deleted the status part of the response, and i worked on the call as it was just the id without anything else and that solved it