Question about codepen tribute project: bootstrap well wont work

Question about codepen tribute project: bootstrap well wont work
0

#1

This is the code Im using to try and create a well in my tribute project but for some reason it isnt working

https://codepen.io/rmatuschka1/pen/egaLWJ

#2

can you post a link to the codepen?


#3

great. now I see you have declared the well but have nothing inside. What is it exactly you are having trouble with?


#4

I have declared it but where is it on the page. Even when I put something inside nothing comes up


#5

okay first thing change the cdn of bootstrap 4 css to 3.3.7 this will get the well working.


#6

Nope, still not working


#7

If i remove the bootrap css 4 and replace it with 3.7 I get the “well” element working perfectly. Maybe I’m not understanding the quetion?


#8

No you are. But for some reason when i replace it it just gets rid of bootstrap completely


#9

Your bootstrap seems to be working for me as well after I replaced bs4 with bs3. Also you were missing a closing > on your div before your class well.


#10

Thanks for telling me about the closing>. even so its not working for me. maybe theres just something up with my laptop or my chrome or something. the laptop is pretty bad


#11

https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.7/css/bootstrap.min.css


#12

thank you jenovs.now it is working


#13

From what i can tell you are still using bootstrap 4. Try the link from jenovs, or this - https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css


#14

Thanks for the help everyone


#15

The change for the Bootstrapp 3.3.7 like @jenovs linked up, works for me too!! problem fixed!


#16

I had the same problem and this worked for me. Looks like bootstrap 4 isn’t compatible with codepen for some reason. Or perhaps the behavior of wells is diffrent.


#17

There are no wells in Bootstrap 4.


#18

I believe “card” replaces “well” in bootstrap 4
https://v4-alpha.getbootstrap.com/migration/#panels-thumbnails-and-wells