Quote Generator Site not Secure Heroku

Quote Generator Site not Secure Heroku
0.0 0

#1

this is my site https://quotegenerator2018.herokuapp.com/ and while I’m using google chrome it shows that it is not secure! I tried looking up how to fix that but honestly I don’t even know where to begin. I know I could pay for heroku’s ssl but I’d rather do it a free way if possible. can anyone point me in the right direction. I know nothing about deployment.


#2

Can you post a screenshot of this message? I am not seeing it when viewing the site via Chrome.

I am however seeing issues with your code (html syntax errors) causing the page not to load a quote on click in Internet Explorer 11. Also, I can only get one quote to load each time I click the new quote button using Chrome.


#3

It’s because the cert domain does not match the Heroku app domain name.

Have a look at this heroku ACM


#4

I had a similar problem before, could get only one quote each time. The api was right but the code was wrong therefore every time got one quote only because the page was reloaded.


#5

Oooof yeah I’ll download internet explorer I’ve never even tried testing on that, worth learning though.


#6

It appears the problem fixed itself I looked back at it and its secure now. Thank you for the SSL article!


#7

Nevermind still broken lol


#8

Hmm I changed that and it did not fix it


#9

and how did you fix it?


#10

I did not fix it, I figured out at the time that each time I could get one quote not because the code was working, only because the page reloaded and it was the case for me. My problem was fixed when my code was right.


#11

I actually fixed it! both problems lol. i typed heroku.com instead of herokuapp.com also litterally attached a random number to the end of the uri forcing axios to make another get request each time. This seems sloppy but apparently thats what jquery does with their false cache.