RDBM course stuck at Mario DB's last challenge

I have gone through all the challenges and I am stuck at the last one,
The command I am supposed to enter is SELECT * FROM characters , I press enter
then click run but I get Test Run Fail

Sorry for your troubles @Jeylani. I’ve seen this issue recently. Did you get it resolved at all? You should be able to click that reset button and then completing the step should work. Let us know how it goes.

Do you remember when you started this course? Like what day you first opened it.

Thanks for your reply.

I have tried again and unfortunately, I am still receiving the same “Test runner failed” error.

Hi y’all, I’ve run into a Test Runner Failed situation too. I completed 70% of the course in the Beta Browser version two days ago, but when I logged back in yesterday, I couldn’t pass the first test from where I’d left off:


I encountered this weird behavior after multiple restarts, and suspect it may have something to do with the Test Runner Failing.

codeally@450693712a97:~$ cd project/
bash: /home/codeally/project/.freeCodeCamp/test/.next_command: Bad message
bash: /home/codeally/project/.freeCodeCamp/test/.next_command: Bad message
bash: /home/codeally/project/.freeCodeCamp/test/.cwd: Bad message
bash: /home/codeally/project/.freeCodeCamp/test/.next_command: Bad message

I am able to successfully connect to the mario_database and add the table:

However, the test does not run and pass automatically like normal, and when I hit Run, it displays the Test Runner Failed message:

Killing the terminal and restarting it also sparks Bad message:

So does logging back into the project:

And the table is still there, but Test Runner still failing:

Hoping that killing the whole thing and starting over isn’t the only way to fix. Any insight, @moT01 ?


Hey @Jeylani @sieis, there’s some discussion around your issues here. I believe they are the same as that because both of your screenshots don’t have the theme applied in the terminal. So something got messed up in the VM I think. Are you seeing all the folders like in the screen shot from that link? If so, it’s probably the same issue. There’s also an issue on GitHub for this. Unfortunately, I don’t know of a way to restore things to get back on track.

Because you are on the last step @Jeylani, I would see if you can just hack the test to pass so you can finish the tutorial. Find the test file for the last step - it will be in the .freeCodeCamp/test folder - and replace what’s in the file with this:

const assert = require('assert');
describe('You',() => {

That should pass the last test/step - I think it will probably work.

You’re at 70% completed @sieis. You could do the same thing, but you would probably have to do that for all the rest of the steps. All I can say is to do that or start over unfortunately - sorry. Unless I’m mistaken and this isn’t the problem.

Ah, dang! Yeah, def the VM is messed up for me. I’m deleting and starting over. I’ll just not close it until finishing entirely this time. I had closed it previously with no issue logging back into the Mario Project, but won’t test fate again. Thanks, @moT01.

Sorry for the late reply,

I just tried it now and it’s not working still

You replaced that test file with my suggestion and it didn’t work @Jeylani?


I did it like this
I hope it’s not incorrect

I thought you were on the last step @Jeylani - this test file says you’re on step 72 (ish). If that’s the most recent (highest numbered) test file, I would recommend starting over. Here’s some instructions on how to do that. You should be able to fly through the progress you will lose. Here’s some motivation: Relational Databases With freeCodeCamp - DEV Community

I thought I was on the last step too haha.

Thanks a lot for the motivation, I guess I have to grind through it again

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.