Receiving same error despite copying hint directions

I believe everything is in the right spot, but I keep getting the same error no matter how my syntax is written in myApp.js:

// running tests
helmet.frameguard() middleware should be mounted correctly
// tests completed

My project link

solution: boilerplate-infosec - Replit

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.115 Safari/537.36

Challenge: Mitigate the Risk of Clickjacking with helmet.frameguard()

Link to the challenge:

You need to install the exact version of helmet asked for in the initial challenge. When I do that your code passes.

Hi lasjorg,

Thanks for your advice, but I have tried the correct version(3.21.3) as well as others like (3.21.0), and (5.1.0).
Because I am a new user, I cannot share all of the screenshots Iā€™d like, but this one shows the error despite having the correct version installed in package.json


.

Remove the caret ^ in front of the helmet version number and try again.

1 Like