Record Collection - it was very hard but I worked on it accidentally

Record Collection - it was very hard but I worked on it accidentally
0.0 0

#1

Hey all,

I’m trying to delete this post but somehow it’s not allowing me to delete it (only edit), so I might as well tell you the story of why I was going to delete it.

Here’s what happened: I was chugging along nicely in the Basic Javascript section up until last week. Then, by accident I must have gone to the Map and clicked on the Record Collection exercise by mistake and then just went ahead and worked on it. The thing is, this exercise is located in the Advanced Algorithm Scripting section. I feel dumb because of my original post below, and kinda smart for solving an advanced problem before I was ready for it. So kind of a happy accident I guess - happy because it made me work very hard and I learned quite a bit from it.

Original post:
"I was on a roll, I was completing exercises daily until I fell upon this (to me) very difficult exercise.
I have just finally solved it after a week of struggling with it. I am super happy about it!
No help was required, other than reading up on various object and array methods and properties.

For some of you, this may have been an easy one, and for others maybe your roadblock happened earlier. I’m posting this mostly to let newer members know that at some point they will get stuck and that’s ok. This exercise made me realize that this won’t be easy and I have much to learn on my own. FCC isn’t going to give me everything I need to solve problems. It’s up to me to do some external research, and that’s the point.

My code is 32 lines long and I feel like it could be shorter but I wouldn’t know how to shorten it.
I had a lot of fun solving this and if anyone has questions about it I’m here to help. Except for now I’m going to bed.

Happy coding all!"


#2

Actually, I noticed that I also finished that one out of sequence. No wonder it was so difficult! I wonder if maybe there is a glitch or if the challenge has been moved because of how difficult it is after we finished it.


#3

I had the same thing happen to me with this task, so it does sound like there is a glitch here (or the task has recently been moved)


#4

I just checked and found the same thing happened to me. I figured this was part of the basic Javascript section.

This was a bit of a wall that really required a bit of research. Maybe it’s meant to test you and not a really a glitch.


#5

So it’s possible then that they moved the exercise during the time that I was working on it? Strange, but not unreasonable - it was incrementally much more difficult then the exercises preceding it.