Record Collection (Objects)

Tell us what’s happening:
Describe your issue in detail here.
Hi,
this is a function that updates an object literal (recordCollection).
I have followed these instructions to create the function:

  • Your function must always return the entire record collection object.
  • If prop isn’t tracks and value isn’t an empty string, update or set that album’s prop to value .
  • If prop is tracks but the album doesn’t have a tracks property, create an empty array and add value to it.
  • If prop is tracks and value isn’t an empty string, add value to the end of the album’s existing tracks array.
  • If value is an empty string, delete the given prop property from the album.

my code is a little different from the solution given, but it works on the console. Kindly help me understand why it gives me errors when i run it on the fcc terminal.
Your code so far


// Setup
var recordCollection = {
2548: {
  albumTitle: 'Slippery When Wet',
  artist: 'Bon Jovi',
  tracks: ['Let It Rock', 'You Give Love a Bad Name']
},
2468: {
  albumTitle: '1999',
  artist: 'Prince',
  tracks: ['1999', 'Little Red Corvette']
},
1245: {
  artist: 'Robert Palmer',
  tracks: []
},
5439: {
  albumTitle: 'ABBA Gold'
}
};

// Only change code below this line
function updateRecords(records, id, prop, value) {
if (prop !== 'tracks' && value.length !== 0) {
  records[id][prop] = value;
} else if (prop == 'tracks' && records[id].hasOwnProperty("tracks") == false) {
  records[id]["tracks"] = [];
  records[id]["tracks"].push(value);
} else if (prop == 'tracks' && value.length !== 0) {
  records[id][prop].push(value);
} else if (value.length == 0) {
  delete records[id][prop];
} else {
  console.log('please enter valid details')
}
return recordCollection;
}

updateRecords(recordCollection, 5439, 'artist', 'ABBA');
  **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.124 Safari/537.36

Challenge: Record Collection

Link to the challenge:

this is not a variable that exist in the function - what happens if a different object is passed in?

1 Like

thank you. i have changed it to the parameter ‘records’. It has worked

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.