Redux - Create a Redux Store

“Uncaught ReferenceError: Redux is not defined.” is shown in my Redux course (I tried first 2 lessons and they both showed this) on both my laptop and mobilephone.
So, I cleared my browser cache, restart and tried different browsers but it is still not solved.
I checked console and they show “net::ERR_CONNECTION_REFUSED” with the link “frame.ts:257”.
In source, “frame.write(content);” in line 257 was underlined with red.
In network, there is redux.min.js and redux-thunk.min.js with with header “Provisional headers are shown”.
My code does not pass even if I have right answer.
I would like to know if there is solution for this? because I saw a lot of people in forum with same problem but I didn’t see solution or is it the problem from my side and if so, how can i fix this?

Your code so far

const reducer = (state = 5) => {
return state;
}
// Redux methods are available from a Redux object
// For example: Redux.createStore()
// Define the store here:

const store = Redux.createStore(reducer)

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36

Challenge: Redux - Create a Redux Store

Link to the challenge:

Works for me.

Make sure you do not have any extensions installed that are blocking it. Try in a private window or maybe try in Firefox as well.

I did everything ( no extension, tried in private window, and Firefox) you said and it is still “Redux is not defined”. T-T
Every lesson that has Redux including ‘React and Redux’ course is showing “Redux is not defined”. T-T

So, it sounds like the problem is on your side. It is trying to download that file and it can’t for whatever reason.

I might look at the network tab in the dev tools and see what it is saying for that file.

I also might just try it out in the browser, putting that file name in the address bar:

https://cdnjs.cloudflare.com/ajax/libs/redux/3.7.2/redux.min.js

You should see several lines of code starting with:

!function(t,e){"object" ...

It said this site can’t be reached.

OK, that suggests to me that there is something in your computer/browser/VPN/firewall/country/etc. that is blocking that site. I don’t know why they would, but it seems to be.

Do you know anyone else in your country that is doing FCC? Or is there another computer you could try it on?

I changed the DNS Server and it works now.
By the way, thanks A LOT for helping me.
[Just in case if someone has the same problem with me
( Control Panel > Network and Sharing Center > Change adapter setting > right click on ur active network > properties > Internet Protocol Version 4 > Preferred DNS server 8.8.8.8 and Alternate DNS server 8.8.4.4)]

1 Like

Good job finding the solution.

1 Like