Reg Kendo versions while upgrading to Angular version 17

I am receiving these following errors while running my frontend solution, please help.
error NG8001: ‘kendo-dialog’ is not a known element:

  1. If ‘kendo-dialog’ is an Angular component, then verify that it is part of this module.
  2. If ‘kendo-dialog’ is a Web Component then add ‘CUSTOM_ELEMENTS_SCHEMA’ to the ‘@NgModule.schemas’ of this component to suppress this message.

error NG8001: ‘router-outlet’ is not a known element:

  1. If ‘router-outlet’ is an Angular component, then verify that it is part of this module.
  2. If ‘router-outlet’ is a Web Component then add ‘CUSTOM_ELEMENTS_SCHEMA’ to the ‘@NgModule.schemas’ of this component to suppress this message.

29
~~~~~~~~~~~~~~~
error NG8001: ‘kendo-dialog-actions’ is not a known element:

  1. If ‘kendo-dialog-actions’ is an Angular component, then verify that it is part of this module.
  2. If ‘kendo-dialog-actions’ is a Web Component then add ‘CUSTOM_ELEMENTS_SCHEMA’ to the ‘@NgModule.schemas’ of this component to suppress this message.

607
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

these are the downloads I have in my package.json.